Page 1 of 1 doesn't work (a big title)

Posted: Sat Aug 03, 2019 7:12 pm
by farter
yes it's just as hilarious as it is. the minimal example is exactly the hello world example on the main page of the official wiki (tested).
i'm on a toshiba laptop, windows 10 1809 64-bit, intel core i3 m-350, ATI Mobility Radeon HD 5145 (Toshiba). love2d 11.2 downloaded just today.
fortunately, i had a raspberry pi (connected through vnc). after sudo apt install love, and uploading the same code, run.


what i wrote is some really basic test code. (tried to draw 10 to 10k of them, along with a simple hello world text) works perfectly on both platforms. config - gammacorrect works on both too (that's why i'm too happy with love2d).
i tried both directly calling print and also copying comic.ttf and newFont setFont then print. both works well on raspi but not my laptop (the font loads (i triggered file not found exception to ensure it can fail)).
i tried both win32 win64 and both love.exe lovec.exe. even run as administrator. all gives the same result.
that's all i know for now.

can anyone help? or what test can i do to help addressing this issue?
fyi i'm using Chinese version of windows. the code contains only ascii characters. may be conversion problem or rendering encoding problem?

Re: doesn't work (a big title)

Posted: Sat Aug 03, 2019 8:15 pm
by slime
Could you try a prerelease nightly build of love 11.3? It has a workaround for a bug like that which affects ATI Radeon HD series GPUs on Windows, so I'm hoping it'll be fixed for you: ... /artifacts

Re: doesn't work (a big title)

Posted: Sun Aug 04, 2019 10:30 am
by farter
hooray it works! thanks for the quick reply in advance.
btw i'm curious about... how soon will this come out?