Having trouble building love from source

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Having trouble building love from source

Post by bizziboi » Thu Mar 17, 2016 3:51 am

I pulled the full source tree (megasource+love) yesterday, but when trying to build it (windows. cmake 3.5.0, VS2013 Express) I have a series of errors, specifically in Freetype. Just curious if others are able to build the current depot.

XxHAMADEHxX
Prole
Posts: 19
Joined: Sun Mar 13, 2016 3:23 am

Re: Having trouble building love from source

Post by XxHAMADEHxX » Thu Mar 17, 2016 5:00 am

Could you post the errors you are getting? :crazy:

bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Re: Having trouble building love from source

Post by bizziboi » Thu Mar 17, 2016 5:17 am

I posted to an existing issue on the bitbucket page here:
https://bitbucket.org/rude/megasource/i ... uild-fails

It seems that when love2d builds it tries to build freetype while including the zlib.h from the zlib directory instead of its own private version. I tried working around it but without luck. Megasource itself builds fine for me, love fails building from VS or the command line.

The errors are (first few anyhow, behaviour changes if I have it include the private zlib, but still fails to build):
InitializeBuildStatus: Touching "freetype.dir\Release\freetype.tlog\unsuccessfulbuild". ClCompile: C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\CL.exe /c /IC:\megasource\build\freetype\include /I"C:\megasource\libs\freetype-2.6.2\include" /I"C:\megasource\libs\freetype-2.6.2." /I"C:\megasource\libs\zlib-1.2.8." /IC:\megasource\build\zlib /nologo /W0 /WX- /MP /O2 /Ob2 /Oy- /D WIN32 /D _WINDOWS /D NDEBUG /D FT2_BUILD_LIBRARY /D "CMAKE_INTDIR=\"Release\"" /D _MBCS /Gm- /MD /GS /arch:IA32 /fp:precise /Zc:wchar_t /Zc:forScope /Fo"freetype.dir\Release\" /Fd"freetype.dir\Release\vc120.pdb" /Gd /TC /analyze- /errorReport:queue "C:\megasource\libs\freetype-2.6.2\src\gzip\ftgzip.c" ftgzip.c C:\megasource\libs\zlib-1.2.8.\zlib.h(86): error C2016: C requires that a struct or union has at least one member [C:\megasource\build\freetype\freetype.vcxproj] C:\megasource\libs\zlib-1.2.8.\zlib.h(86): error C2061: syntax error : identifier 'z_const'

This is why I wonder if it's just me, it could be that my default VC include paths are messed up.

User avatar
slime
Solid Snayke
Posts: 2902
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Having trouble building love from source

Post by slime » Thu Mar 17, 2016 11:11 am

Some people have that error, but it hasn't happened to me or the nightly builds on Appveyor, so it makes tracking down the actual problem kind of hard.

A new version of FreeType was released a little while ago, I'll try updating megasource's copy of it this weekend to see if it helps, maybe.

bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Re: Having trouble building love from source

Post by bizziboi » Fri Mar 18, 2016 3:40 am

Hmmm, that's odd.

Is there any way to get insight in what's installed on the buildmachine for the nightly build/AppVeyor? OS, versions, service packs, whatnot?
Does the buildmachine do clean builds, or just build changes?

It seems obvious that the makefiles are missing a dependency and rely on something being set a certain way in the build environment if it fails in a similar way on some machines but not others.

I guess I'll start by installing an older version of cmake, building from a different account, I don't have access to another machine (well, I do but it has a cmake that's too old and I can't upgrade it)

bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Re: Having trouble building love from source

Post by bizziboi » Fri Mar 18, 2016 4:59 am

Okay, installing Cmake 3.0 instead of latest stable made it build for me (I guess CMake added an option that does not default to previous behaviour.....yeah, hmmmmm.....).

Note that the documentation states cmake 2.8.12 or up, but that won't generate VS2013 solutions.

bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Re: Having trouble building love from source

Post by bizziboi » Thu Aug 04, 2016 6:30 am

Well, this sucks.

Just grabbed latest and the problem is back.
The cmake files now need at least CMake 3.1,(it used to work with 3.0) but cmake 3.1 will misgenerate the solution and the project will not build, at least not from Visual Studio 2013, the same bug with freetype is back.

:(

bizziboi
Citizen
Posts: 55
Joined: Sat Apr 16, 2011 9:24 am

Re: Having trouble building love from source

Post by bizziboi » Thu Aug 04, 2016 6:58 am

Okay, found it.
Commit 991f387 broke it, as it mandates minimum CMake 3.1 - Windows won't build with projects generated with a CMake newer than 3.0.

(does the buildmachine actually do a full clean (ie regenerate) and rebuild? I'm really surprised this works for the buildmachine)

User avatar
4aiman
Party member
Posts: 248
Joined: Sat Jan 16, 2016 10:30 am

Re: Having trouble building love from source

Post by 4aiman » Thu Aug 04, 2016 9:02 am

A couple of quick questions on topic.
I've installed a distro called SliTaz. A neat lightweight distro.
The thing is, love2d 0.10 requires gcc 4.7 whereas Slitaz have gcc of version 4.6.3.
Is it true that 4.7 is really needed due to it's features, or I can "fix" the sources to compile with 4.6.3?

Now, love2d 0.9 can be compiled with gcc 4.6.3, but it requires libdevil. Which seemingly builds

Code: Select all

sudo make install
Password: 
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Making install in lib
make[1]: Entering directory '/home/chaiman/devil-1.7.8/lib'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8/lib'
test -z "/usr/local/lib" || ../build-aux/install-sh -c -d "/usr/local/lib"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
 /bin/bash ../libtool   --mode=install /usr/bin/install -c  'libIL.la' '/usr/local/lib/libIL.la'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
libtool: install: /usr/bin/install -c .libs/libIL.so.1.1.0 /usr/local/lib/libIL.so.1.1.0
libtool: install: (cd /usr/local/lib && { ln -s -f libIL.so.1.1.0 libIL.so.1 || { rm -f libIL.so.1 && ln -s libIL.so.1.1.0 libIL.so.1; }; })
libtool: install: (cd /usr/local/lib && { ln -s -f libIL.so.1.1.0 libIL.so || { rm -f libIL.so && ln -s libIL.so.1.1.0 libIL.so; }; })
libtool: install: /usr/bin/install -c .libs/libIL.lai /usr/local/lib/libIL.la
libtool: install: /usr/bin/install -c .libs/libIL.a /usr/local/lib/libIL.a
libtool: install: chmod 644 /usr/local/lib/libIL.a
libtool: install: ranlib /usr/local/lib/libIL.a
libtool: finish: PATH="/home/chaiman/.local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/bash ../libtool   --mode=install /usr/bin/install -c  'libILU.la' '/usr/local/lib/libILU.la'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
libtool: install: warning: relinking `libILU.la'
libtool: install: (cd /home/chaiman/devil-1.7.8/lib; /bin/bash /home/chaiman/devil-1.7.8/libtool  --tag CC --mode=relink gcc -msse -msse2 -msse3 -g -O2 -version-info 2:0:1 -o libILU.la -rpath /usr/local/lib libILU_la-ilu_alloc.lo libILU_la-ilu_internal.lo libILU_la-ilu_noise.lo libILU_la-ilu_scale.lo libILU_la-ilu_error.lo libILU_la-ilu_main.lo libILU_la-ilu_rotate.lo libILU_la-ilu_scaling.lo libILU_la-ilu_filter.lo libILU_la-ilu_manip.lo libILU_la-ilu_scale2d.lo libILU_la-ilu_states.lo libILU_la-ilu_filter_rcg.lo libILU_la-ilu_mipmap.lo libILU_la-ilu_scale3d.lo libILU_la-ilu_utilities.lo libILU_la-ilu_region.lo libIL.la -lm -lz )
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libpng12.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libjpeg.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libstdc++.la' seems to be moved
libtool: relink: gcc -shared  .libs/libILU_la-ilu_alloc.o .libs/libILU_la-ilu_internal.o .libs/libILU_la-ilu_noise.o .libs/libILU_la-ilu_scale.o .libs/libILU_la-ilu_error.o .libs/libILU_la-ilu_main.o .libs/libILU_la-ilu_rotate.o .libs/libILU_la-ilu_scaling.o .libs/libILU_la-ilu_filter.o .libs/libILU_la-ilu_manip.o .libs/libILU_la-ilu_scale2d.o .libs/libILU_la-ilu_states.o .libs/libILU_la-ilu_filter_rcg.o .libs/libILU_la-ilu_mipmap.o .libs/libILU_la-ilu_scale3d.o .libs/libILU_la-ilu_utilities.o .libs/libILU_la-ilu_region.o   -Wl,-rpath -Wl,/usr/local/lib -L/usr/local/lib -lIL -L/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../.. -L/usr/lib -lpng12 -llcms -ljpeg -lstdc++ -lm -lz  -msse -msse2 -msse3   -Wl,-soname -Wl,libILU.so.1 -o .libs/libILU.so.1.1.0
libtool: install: /usr/bin/install -c .libs/libILU.so.1.1.0T /usr/local/lib/libILU.so.1.1.0
libtool: install: (cd /usr/local/lib && { ln -s -f libILU.so.1.1.0 libILU.so.1 || { rm -f libILU.so.1 && ln -s libILU.so.1.1.0 libILU.so.1; }; })
libtool: install: (cd /usr/local/lib && { ln -s -f libILU.so.1.1.0 libILU.so || { rm -f libILU.so && ln -s libILU.so.1.1.0 libILU.so; }; })
libtool: install: /usr/bin/install -c .libs/libILU.lai /usr/local/lib/libILU.la
libtool: install: /usr/bin/install -c .libs/libILU.a /usr/local/lib/libILU.a
libtool: install: chmod 644 /usr/local/lib/libILU.a
libtool: install: ranlib /usr/local/lib/libILU.a
libtool: finish: PATH="/home/chaiman/.local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/bash ../libtool   --mode=install /usr/bin/install -c  'libILUT.la' '/usr/local/lib/libILUT.la'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
libtool: install: warning: relinking `libILUT.la'
libtool: install: (cd /home/chaiman/devil-1.7.8/lib; /bin/bash /home/chaiman/devil-1.7.8/libtool  --tag CC --mode=relink gcc -msse -msse2 -msse3 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -g -O2 -lXrender -lXext -lX11 -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -lGLU -lGL -lm -lGL -lm -version-info 2:0:1 -o libILUT.la -rpath /usr/local/lib libILUT_la-ilut_main.lo libILUT_la-ilut_states.lo libILUT_la-ilut_internal.lo libILUT_la-ilut_sdlsurface.lo libILUT_la-ilut_opengl.lo libILUT_la-ilut_x11.lo libILU.la -lm -lz )
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libpng12.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libjpeg.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libstdc++.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libpng12.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libjpeg.la' seems to be moved
libtool: relink: warning: `/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../../libstdc++.la' seems to be moved
libtool: relink: gcc -shared  .libs/libILUT_la-ilut_main.o .libs/libILUT_la-ilut_states.o .libs/libILUT_la-ilut_internal.o .libs/libILUT_la-ilut_sdlsurface.o .libs/libILUT_la-ilut_opengl.o .libs/libILUT_la-ilut_x11.o   -Wl,-rpath -Wl,/usr/local/lib -L/home/chaiman/devil-1.7.8/lib/.libs -L/usr/lib -lXrender -lXext -lX11 -lxcb -lXau -lXdmcp -ldl -lSDL -lpthread -lGLU -lGL -L/usr/local/lib -lILU -L/usr/lib/gcc/i486-slitaz-linux/4.6.3/../../.. -lIL -lpng12 -llcms -ljpeg -lstdc++ -lm -lz  -msse -msse2 -msse3 -Wl,-rpath -Wl,/usr/lib   -Wl,-soname -Wl,libILUT.so.1 -o .libs/libILUT.so.1.1.0
libtool: install: /usr/bin/install -c .libs/libILUT.so.1.1.0T /usr/local/lib/libILUT.so.1.1.0
libtool: install: (cd /usr/local/lib && { ln -s -f libILUT.so.1.1.0 libILUT.so.1 || { rm -f libILUT.so.1 && ln -s libILUT.so.1.1.0 libILUT.so.1; }; })
libtool: install: (cd /usr/local/lib && { ln -s -f libILUT.so.1.1.0 libILUT.so || { rm -f libILUT.so && ln -s libILUT.so.1.1.0 libILUT.so; }; })
libtool: install: /usr/bin/install -c .libs/libILUT.lai /usr/local/lib/libILUT.la
libtool: install: /usr/bin/install -c .libs/libILUT.a /usr/local/lib/libILUT.a
libtool: install: chmod 644 /usr/local/lib/libILUT.a
libtool: install: ranlib /usr/local/lib/libILUT.a
libtool: finish: PATH="/home/chaiman/.local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
test -z "/usr/local/include/IL" || ../build-aux/install-sh -c -d "/usr/local/include/IL"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
 /usr/bin/install -c -m 644 './../include/IL/devil_cpp_wrapper.hpp' '/usr/local/include/IL/devil_cpp_wrapper.hpp'
 /usr/bin/install -c -m 644 './../include/IL/il.h' '/usr/local/include/IL/il.h'
 /usr/bin/install -c -m 644 './../include/IL/ilu.h' '/usr/local/include/IL/ilu.h'
 /usr/bin/install -c -m 644 './../include/IL/ilu_region.h' '/usr/local/include/IL/ilu_region.h'
 /usr/bin/install -c -m 644 './../include/IL/ilut.h' '/usr/local/include/IL/ilut.h'
make[2]: Leaving directory '/home/chaiman/devil-1.7.8/lib'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8/lib'
Making install in bin
make[1]: Entering directory '/home/chaiman/devil-1.7.8/bin'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8/bin'
test -z "/usr/local/bin" || ../build-aux/install-sh -c -d "/usr/local/bin"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
  /bin/bash ../libtool   --mode=install /usr/bin/install -c 'ilur' '/usr/local/bin/ilur'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
libtool: install: /usr/bin/install -c .libs/ilur /usr/local/bin/ilur
test -z "/usr/local/share/devil/examples" || ../build-aux/install-sh -c -d "/usr/local/share/devil/examples"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Leaving directory '/home/chaiman/devil-1.7.8/bin'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8/bin'
Making install in docs
make[1]: Entering directory '/home/chaiman/devil-1.7.8/docs'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8/docs'
make[2]: Nothing to be done for 'install-exec-am'.
test -z "/usr/local/share/info" || ../build-aux/install-sh -c -d "/usr/local/share/info"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
 /usr/bin/install -c -m 644 './DevIL_manual.info' '/usr/local/share/info/DevIL_manual.info'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Leaving directory '/home/chaiman/devil-1.7.8/docs'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8/docs'
Making install in test
make[1]: Entering directory '/home/chaiman/devil-1.7.8/test'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8/test'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/home/chaiman/devil-1.7.8/test'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8/test'
Making install in data
make[1]: Entering directory '/home/chaiman/devil-1.7.8/data'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8/data'
make[2]: Nothing to be done for 'install-exec-am'.
test -z "/usr/local/lib/pkgconfig" || ../build-aux/install-sh -c -d "/usr/local/lib/pkgconfig"
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
 /usr/bin/install -c -m 644 'IL.pc' '/usr/local/lib/pkgconfig/IL.pc'
 /usr/bin/install -c -m 644 'ILU.pc' '/usr/local/lib/pkgconfig/ILU.pc'
 /usr/bin/install -c -m 644 'ILUT.pc' '/usr/local/lib/pkgconfig/ILUT.pc'
make[2]: Leaving directory '/home/chaiman/devil-1.7.8/data'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8/data'
make[1]: Entering directory '/home/chaiman/devil-1.7.8'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
make[2]: Entering directory '/home/chaiman/devil-1.7.8'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/home/chaiman/devil-1.7.8'
make[1]: Leaving directory '/home/chaiman/devil-1.7.8'
but love2d still doesn't see it (I did re-run ./configure):

Code: Select all

configure: error: L��VE needs "DevIL", please install "DevIL" with development files and try again
How to tell love2d "Hey! *Here* is where the DevIl is!"?

It's a shame that deb/rpm-converted packages can't install liblove...

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: Having trouble building love from source

Post by bartbes » Thu Aug 04, 2016 2:43 pm

4aiman wrote:A couple of quick questions on topic.
I'm not sure I'd consider hijacking a topic to be on-topic.
4aiman wrote:Is it true that 4.7 is really needed due to it's features, or I can "fix" the sources to compile with 4.6.3?
In the LÖVE codebase we picked a set of (old!) compilers to target, which includes gcc 4.7. To put this in perspective: gcc 4.7 was released in 2012. Even debian, known for its old packages in the stable version, ships gcc 4.7 in the previous stable version. Now, I'm not saying it will be impossible to compile with an older gcc version, but you'll probably have to modify a bunch of things yourself.
4aiman wrote: How to tell love2d "Hey! *Here* is where the DevIl is!"?
Conveniently, the configure script has a help option (--help) which shows you all the ways you can tell it how to find stuff. Since DevIL installed a pkg-config file (outside of its normal search path), it's probably easiest to override that, as follows:

Code: Select all

./configure PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
Alternatively, you can specify devil_CFLAGS and devil_LIBS yourself, their values would probably by "-I/usr/local/include" and "-L/usr/local/lib -lIL", respectively.
bizziboi wrote: (does the buildmachine actually do a full clean (ie regenerate) and rebuild? I'm really surprised this works for the buildmachine)
Yes, it does. And it does build with VS2013, you can find the script here: https://bitbucket.org/rude/love/src/eaf ... pveyor.yml

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 13 guests