build LOVE 0.9.0 on MSVC++ 2010 Express

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
User avatar
AntonioModer
Party member
Posts: 202
Joined: Fri Jun 15, 2012 5:31 pm
Location: Belarus
Contact:

build LOVE 0.9.0 on MSVC++ 2010 Express

Post by AntonioModer » Sat Nov 30, 2013 5:24 pm

How easy can build last LOVE 0.9.0 ?
I download sources from:
https://bitbucket.org/rude/love
https://bitbucket.org/rude/megasource
And now I suffer with copying "sources" and "includes" from megasource to love, when MSVC++ gives me compiling error.
But i don't yet build final love.exe and love.dll and other.
Help please.

User avatar
Boolsheet
Inner party member
Posts: 780
Joined: Wed Dec 29, 2010 4:57 am
Location: Switzerland

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by Boolsheet » Sat Nov 30, 2013 6:16 pm

Prerequisites
  • DirectX SDK (required for SDL2).
  • CMake 2.8.11.
Did you install these?

If yes, please post the actual error message that you get. It would be best to post all commands you use and all their output. It's easier to tell you what went wrong then.
Shallow indentations.

User avatar
AntonioModer
Party member
Posts: 202
Joined: Fri Jun 15, 2012 5:31 pm
Location: Belarus
Contact:

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by AntonioModer » Sat Nov 30, 2013 7:16 pm

Boolsheet wrote:
Prerequisites
  • DirectX SDK (required for SDL2).
  • CMake 2.8.11.
Did you install these?

If yes, please post the actual error message that you get. It would be best to post all commands you use and all their output. It's easier to tell you what went wrong then.
Yes, i install these. I run CMake-gui, enter source code path ".../megasource", enter configure VS 2010, and CMake-gui gives error:
CMakeOutput.log
(18.9 KiB) Downloaded 143 times
CMakeError.log
(5.91 KiB) Downloaded 156 times
I am not a programmer, i amateur in compiling cross-platform source code.

User avatar
Boolsheet
Inner party member
Posts: 780
Joined: Wed Dec 29, 2010 4:57 am
Location: Switzerland

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by Boolsheet » Sat Nov 30, 2013 8:23 pm

Uh. With my very limited CMake knowledge, I can't tell where the error occurs.
Shallow indentations.


User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by bartbes » Sat Nov 30, 2013 9:29 pm

Given the fact the output files are unreadable (or are they in some magic encoding?) and that msb4025 appears to be a read error in the project file, could this be a character encoding issue? Have you tried building it in a directory without special characters?

User avatar
Boolsheet
Inner party member
Posts: 780
Joined: Wed Dec 29, 2010 4:57 am
Location: Switzerland

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by Boolsheet » Sat Nov 30, 2013 9:38 pm

I didn't wan't it to be true, but bartbes is correct. The ampersands are haunting me lately and software that craps out on it is everywhere! :(
Shallow indentations.

User avatar
AntonioModer
Party member
Posts: 202
Joined: Fri Jun 15, 2012 5:31 pm
Location: Belarus
Contact:

Re: build LOVE 0.9.0 on MSVC++ 2010 Express

Post by AntonioModer » Tue Dec 03, 2013 3:20 pm

Hi bartbes, boolsheet. I apologize for the long absence of my answer to the question.
I translate the log files from Russian to English in "translate.google.com". I build souce code with cmake:

Code: Select all

cmake -G "Visual Studio 10" -H. -Bbuild
cmake --build build --target megatest --config Release

Post Reply

Who is online

Users browsing this forum: No registered users and 30 guests