Problem with module

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: Problem with module

Post by rude »

Are you saying /usr/lib and /usr/local/lib should both be checked? You can put the modules in the same directory as the binary too, by the way.

Also: if you have the latest trunk available, check out makefile-simple, which is a version of the old makefiles which is easier to tweak (i.e. change linker flags, etc). (While we still wait for automagic completion).
User avatar
farvardin
Party member
Posts: 164
Joined: Sat Jun 28, 2008 6:46 pm

Re: Problem with module

Post by farvardin »

on linux you can't put the lib together with the executable binary (I mean, most distributions won't accept this). And when you build the binary, it should be linked to folder requested by the configure (default is usually /usr/local/lib but on request, for official distribution packages, it will be /usr/lib )

I think by default it should also check for every folder that is in the PATH. I've tried to change my path, but it didn't seem to make it work.
But it can also work if you put everything in the same folder and start the executable from this folder.

I'm only using the official release at the moment, and I'm especially waiting for the autoconf version.
User avatar
tido
Prole
Posts: 28
Joined: Mon Feb 04, 2008 4:08 pm
Contact:

Re: Problem with module

Post by tido »

Actually, if you

Code: Select all

make install
, it should install the modules and executable into their proper places. Some distros don't bother looking under /usr/local/ because everything installs to /usr/. I don't think we'll ever put them under /usr/local/ unless anybody here is passionately for it.
User avatar
farvardin
Party member
Posts: 164
Joined: Sat Jun 28, 2008 6:46 pm

Re: Problem with module

Post by farvardin »

the latest release doesn't support make install yet. Maybe the svn and the future release then?
User avatar
tido
Prole
Posts: 28
Joined: Mon Feb 04, 2008 4:08 pm
Contact:

Re: Problem with module

Post by tido »

Sorry, I was talking about the latest SVN. :oops:
User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: Problem with module

Post by rude »

Chrishas, did you ever get LÖVE to run properly? I installed Slackware on a virtual machine, but frankly, it took too long to get all the dependencies etc, so I never got around to testing it.

You should try the 0.3.2 source. It has static modules, maybe that will help. Also, it has more symbols in the makefile, which will make it easier to change -llua5.1 to -llua, etc.
Post Reply

Who is online

Users browsing this forum: No registered users and 37 guests