AGen

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
miko
Party member
Posts: 410
Joined: Fri Nov 26, 2010 2:25 pm
Location: PL

Re: AGen

Post by miko »

TechnoCat wrote:
ivan wrote:Sorry to bump this super old topic but (yay) AGen is now available for both Win and MacOS:
http://2dengine.com/page.php?p=download
Congratulations on involving OSX into the AGen builds. I want to try AGen out at some point.
Me too, but I will have to wait for the linux version... :|
My lovely code lives at GitHub: http://github.com/miko/Love2d-samples
User avatar
ivan
Party member
Posts: 1719
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: AGen

Post by ivan »

Hey everybody this is not Love2D-related but I hope the mods won't be too upset.
We have a Linux build of the engine, but before we can release it, we need some feedback from Linux gamers.
There is an experimental Linux build of one of our games:
http://2dengine.com/commando/8Bit_Comma ... 86.tar.bz2
Please try it out and let me know if you experience any issues.

Dependencies:
- audio: ogg/vorbis and openAL
- gamepads: SDL
- graphics: openGL

It can be extracted in a private directory or under /usr or /usr/local. Thanks so much!
User avatar
miko
Party member
Posts: 410
Joined: Fri Nov 26, 2010 2:25 pm
Location: PL

Re: AGen

Post by miko »

ivan wrote: Please try it out and let me know if you experience any issues.
Works perfectly for me, even with gamepads.
The only issue I have is with video mode changing. When setting from windowed to fullscreen, and then do windowed again, i get:

Code: Select all

[agen] version [1.3.10] built on [Apr 29 2013 14:03:42] starting
[agen-x11] running out of [/tmp/8-Bit Commando/share/agen/commando]
[agen-x11] Loading plugin libAgenOGL.so
[agen-x11] GLX version 1.4 detected.
[agen-x11] XRandr version 1.4 detected.
[agen-x11] Loading plugin libAgenSDLinput.so
[agen-sdl] SDL version 1.2.15 detected.
[agen-x11] Loading plugin libAgenOAL.so
[agen] found default video [x11]
[agen] found system keyboard.
[agen] found system mouse.
[agen] Found controller [1.SL-4446-BK]
[agen] found default audio [OpenAL Soft]
[agen] will load file [Scripts/main.lua]
[agen-x11] initialized direct rendering context
[agen-opengl] OpenGL version 3.0 Mesa 9.1.1
[agen-opengl] will use OpenGL 2.0 [GL_ARB_vertex_shader] shader.
[agen-opengl] will use OpenGL 2.0 vertex buffers
[agen-x11] fontconfig version [21092]
[agen] Font already released
[agen] Font already released
[agen-x11] initialized direct rendering context
[agen-opengl] OpenGL version 3.0 Mesa 9.1.1
[agen-opengl] will use OpenGL 2.0 [GL_ARB_vertex_shader] shader.
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Value in failed request:  0x28
  Serial number of failed request:  2857
  Current serial number in output stream:  2857
AL lib: (EE) alc_cleanup: 1 device not closed
Another video issue is when changing resolution: when changinx from 800x600 to the next 1024x768, everything is OK. But then whanging to the next one 1600x900 displays options menu for a fraction of second, then the screen becomes black (music continues to play). Pressing ENTER again does not do anything (like changing resolution once more).

Code: Select all

[agen] version [1.3.10] built on [Apr 29 2013 14:03:42] starting
[agen-x11] running out of [/tmp/8-Bit Commando/share/agen/commando]
[agen-x11] Loading plugin libAgenOGL.so
[agen-x11] GLX version 1.4 detected.
[agen-x11] XRandr version 1.4 detected.
[agen-x11] Loading plugin libAgenSDLinput.so
[agen-sdl] SDL version 1.2.15 detected.
[agen-x11] Loading plugin libAgenOAL.so
[agen] found default video [x11]
[agen] found system keyboard.
[agen] found system mouse.
[agen] Found controller [1.SL-4446-BK]
[agen] found default audio [OpenAL Soft]
[agen] will load file [Scripts/main.lua]
[agen-x11] initialized direct rendering context
[agen-opengl] OpenGL version 3.0 Mesa 9.1.1
[agen-opengl] will use OpenGL 2.0 [GL_ARB_vertex_shader] shader.
[agen-opengl] will use OpenGL 2.0 vertex buffers
[agen-x11] fontconfig version [21092]
[agen] Font already released
[agen] Font already released
[agen-x11] initialized direct rendering context
[agen-opengl] OpenGL version 3.0 Mesa 9.1.1
[agen-opengl] will use OpenGL 2.0 [GL_ARB_vertex_shader] shader.

[agen-x11] initialized direct rendering context
[agen-opengl] OpenGL version 3.0 Mesa 9.1.1
[agen-opengl] will use OpenGL 2.0 [GL_ARB_vertex_shader] shader.
Anyways, those are minor issues. The game is perfectly playable.
Tested on archlinux, dell latitude e6430

Edit:
After playing a little longer, I found a critical error. It happens at the same place every time (after the second plane), the application crashes with floating point exception, related to Box2D. Here is gdb backtrace:

Code: Select all

Core was generated by `./bin/8bit_commando'.
Program terminated with signal 8, Arithmetic exception.
#0  0xf1cedbe4 in b2RevoluteJoint::InitVelocityConstraints(b2TimeStep const&)
    () from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
(gdb) bt
#0  0xf1cedbe4 in b2RevoluteJoint::InitVelocityConstraints(b2TimeStep const&)
    () from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
#1  0xf1cfa21c in b2Island::Solve(b2TimeStep const&, b2Vec2 const&, bool, bool) () from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
#2  0xf1cefaa4 in b2World::Solve(b2TimeStep const&) ()
   from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
#3  0xf1cf050f in b2World::Step(float, int) ()
   from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
#4  0xf1cd8fae in tolua_AgenBox2D_b2World_Step00(lua_State*) ()
   from /home/miko/8-Bit Commando/share/agen/Extensions/dll/Box2D.so
#5  0xf76b8733 in luaD_precall ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#6  0xf76bceb4 in luaV_execute ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#7  0xf76b9600 in luaD_call ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#8  0xf76b4671 in f_call ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#9  0xf76b7963 in luaD_rawrunprotected ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#10 0xf76b7dba in luaD_pcall ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#11 0xf76b4ccd in lua_pcall ()
   from /home/miko/8-Bit Commando/bin/../lib/libAgenLua.so.5.1
#12 0x08075529 in LuaTimer::Update() ()
#13 0x0806368c in AgenMain() ()
#14 0x0807120e in main ()

My lovely code lives at GitHub: http://github.com/miko/Love2d-samples
User avatar
josefnpat
Inner party member
Posts: 955
Joined: Wed Oct 05, 2011 1:36 am
Location: your basement
Contact:

Re: AGen

Post by josefnpat »

It ran really well w/ controller on my archbox as well;
Linux seppi7 3.8.10-1-ARCH #1 SMP PREEMPT Sat Apr 27 12:36:59 CEST 2013 x86_64 GNU/Linux
After a while, I got this;
Floating point exception (core dumped)
Missing Sentinel Software | Twitter

FORCIBLY IGNORED.
<leafo> when in doubt delete all of your code
<bartbes> git rm -r *
<bartbes> git commit -m "Fixed all bugs"
<bartbes> git push
User avatar
ivan
Party member
Posts: 1719
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: AGen

Post by ivan »

Sorry to bump an old topic but check it out, we've just released our Box2D editor:
http://2dengine.com/bin/release/boxy.1.3.10.zip
Image
It can output and load XML files (using its own schema).
I tried to program a Love2D loader but couldn't get LuaXML to work properly with Love2D.
Basically, you need a script that can iterate the XML file and that creates corresponding bodies/shapes in Love2D.
A triangulation lib may be necessary to decompose concave polygons.
Oh ya, and the editor only supports 3-4 basic joints types but it's sufficient to make some pretty sweet physics levels.
jjmafiae
Party member
Posts: 1331
Joined: Tue Jul 24, 2012 8:22 am

Re: AGen

Post by jjmafiae »

if anyone wants cross platform 3D lua engine there is always source engine (or what i call it: sauce engine)
bekey
Party member
Posts: 255
Joined: Tue Sep 03, 2013 6:27 pm

[]

Post by bekey »

-snip-
Last edited by bekey on Fri Jan 24, 2014 2:03 am, edited 1 time in total.
jjmafiae
Party member
Posts: 1331
Joined: Tue Jul 24, 2012 8:22 am

Re: AGen

Post by jjmafiae »

all this time i thought source used lua as the main language.... all this time :(
User avatar
ivan
Party member
Posts: 1719
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: AGen

Post by ivan »

Hey everybody, I need some help with a non-love2d project.
Would be very greatful if anybody with Windows 8 (on a multitouch device) would run the following test:
http://2dengine.com/ftm/multitouch.zip
Just extract and run "agen.exe" then you will be see a black screen saying "multitouch test".
The point is to try and see if multitouch input works at all.
Just make contact with the two or more fingers and see if it's detected.
Much appreciated if anybody could confirm that it works!
Thanks so much.
davisdude
Party member
Posts: 1154
Joined: Sun Apr 28, 2013 3:29 am
Location: North Carolina

Re: AGen

Post by davisdude »

I'm not sure what was supposed to do when touched with more than one finger, but here's what I got:
- Horizontal sliding- Makes little arrow pointing side-to-side. Works with 2+ fingers.
- Vertical sliding- Makes little vertical arrow. Works with 2 finger, not 3. Didn't test any further.
- No diagonal or other movements detected.
GitHub | MLib - Math and shape intersections library | Walt - Animation library | Brady - Camera library with parallax scrolling | Vim-love-docs - Help files and syntax coloring for Vim
Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests