Search found 41 matches

by khamarr3524
Wed Oct 08, 2014 2:45 pm
Forum: Support and Development
Topic: Downsampling issues
Replies: 6
Views: 1339

Downsampling issues

Hey everyone, I'm working on a project currently and I'm having an issue with my Graphics settings UI. I'm using several libraries from this forum, all with due credit I assure you, and at first it seemed as though these complexities in my code could have been the cause of this issue but after runni...
by khamarr3524
Tue Sep 23, 2014 3:07 pm
Forum: Support and Development
Topic: Luadoc for 0.9.1?
Replies: 0
Views: 597

Luadoc for 0.9.1?

Hey I was looking around for a luadoc for Love2D to use in eclipse but i only found one up to 0.8.0 here. Is anyone working on or have an 0.9.1 version?
by khamarr3524
Wed May 07, 2014 4:13 am
Forum: Libraries and Tools
Topic: Löve Frames - A GUI Library
Replies: 380
Views: 157541

Re: Löve Frames - A GUI Library

Is this library still being maintained or planned to be updated to 0.9.1?
by khamarr3524
Sat May 03, 2014 6:33 pm
Forum: Support and Development
Topic: Difference Between love.load() and Top of File?
Replies: 3
Views: 678

Re: Difference Between love.load() and Top of File?

I believe one of the main points is that with love.load you can pass command line arguments to Love.

Please see: http://www.love2d.org/wiki/love.load This is where I got the information.
by khamarr3524
Sat May 03, 2014 1:35 am
Forum: Support and Development
Topic: Grid displayed on Rendering?
Replies: 8
Views: 1808

Re: Grid displayed on Rendering?

Although this is not concerning this, when I'm moving my units w/ the camera attached I get unit lag only. The Grid renders fine, I'm thinking because I have a buffer in place. Is there a way to make the unit not lag? The unit has a fixed speed, when a key is pressed the unit is moved in a certain d...
by khamarr3524
Fri May 02, 2014 7:59 pm
Forum: Support and Development
Topic: Grid displayed on Rendering?
Replies: 8
Views: 1808

Re: Grid displayed on Rendering?

So in the rendering I would draw the tiles at offsets such that x = positionX + (2*tilePosition) + 1 and Y? Or are you talking about when I set the quads?
by khamarr3524
Fri May 02, 2014 2:40 am
Forum: Support and Development
Topic: Grid displayed on Rendering?
Replies: 8
Views: 1808

Re: Grid displayed on Rendering?

I don't think I quite understand how to do the spacing for these pictures. My current method of pulling graphics is based on the size of the tile doing a loop like: for j = 1, #map.tilesets[i].tiles do if b * o.tileWidth == o.tileset[i].imageWidth then a = a + 1 b = 1 end o.tile[j] = {} o.tile[j].pr...
by khamarr3524
Fri May 02, 2014 1:55 am
Forum: Support and Development
Topic: Grid displayed on Rendering?
Replies: 8
Views: 1808

Grid displayed on Rendering?

Hello, I'm working on the display for my map and I've found that upon moving along the x direction, a strange graphical bug is encountered. Can anyone explain / fix this? Grid:render(lg) function Grid:render(lg) local floor = math.floor local buffer = 2 local x, y = self.camera:getPosition() local w...
by khamarr3524
Fri Sep 06, 2013 10:39 pm
Forum: Support and Development
Topic: Issues with Metatables and Logging
Replies: 5
Views: 1041

Re: Issues with Metatables and Logging

Ah, i forgot that .syntax doesn't carry the class over. Thanks so much, I knew it was simple.
by khamarr3524
Fri Sep 06, 2013 2:29 am
Forum: Support and Development
Topic: Issues with Metatables and Logging
Replies: 5
Views: 1041

Re: Issues with Metatables and Logging

Here's the .love. I believe a lot of the code is probably messy and needs to be redone entirely, it's probably the cause of my problem. I've been tweaking it for a few days now. Edit: Most of my questions were really on how to best implement these structural ideas. I would like to find the best impl...