Search found 6 matches

by DoggylovesLove2D
Thu Mar 10, 2022 2:03 am
Forum: Support and Development
Topic: Struggle Attaching Collision to an Object that is Following the Player
Replies: 0
Views: 3544

Struggle Attaching Collision to an Object that is Following the Player

Hello all, I apologize for asking for help again, but I have spent about 2 hours trying different methods of attaching the collision box to the object following the player and I can't seem to figure it out I have tried replicating what I had set up for the player's collision, but it did not work out...
by DoggylovesLove2D
Fri Mar 04, 2022 10:21 pm
Forum: Support and Development
Topic: [SOLVED] STI Not Working?
Replies: 10
Views: 5034

Re: STI Not Working?

Karai17 wrote: Fri Mar 04, 2022 9:27 pm yeah, your map.lua is just a renamed xml file.. it needs to be an actual lua file. File > Export As > Lua
It worked! I didn't realize there was a drop-down menu when exporting the map :death:

Thank you all for helping me out!
by DoggylovesLove2D
Fri Mar 04, 2022 5:18 pm
Forum: Support and Development
Topic: [SOLVED] STI Not Working?
Replies: 10
Views: 5034

Re: STI Not Working?

Karai17 wrote: Thu Mar 03, 2022 7:26 pm upload a full .zip or .love file of your game and we can take a look.
Will do. I didn't realize I had to zip the file to be able to share it :?
by DoggylovesLove2D
Wed Mar 02, 2022 10:37 pm
Forum: Support and Development
Topic: [SOLVED] STI Not Working?
Replies: 10
Views: 5034

Re: STI Not Working?

Is there a way to change it?
by DoggylovesLove2D
Wed Mar 02, 2022 5:41 pm
Forum: Support and Development
Topic: [SOLVED] STI Not Working?
Replies: 10
Views: 5034

Re: STI Not Working?

Hello there, Thanks for your help, but weirdly I am still facing some issues here is the error code: Error libraries/sti/utils.lua:195: Could not open file ../GameLove2D/map.png. Does not exist. Traceback [love "callbacks.lua"]:228: in function 'handler' [C]: in function 'newImageData' lib...
by DoggylovesLove2D
Tue Mar 01, 2022 4:26 pm
Forum: Support and Development
Topic: [SOLVED] STI Not Working?
Replies: 10
Views: 5034

[SOLVED] STI Not Working?

Hey All, I'm currently struggling to get my tiled map to load properly. I followed a Youtube video ( https://youtu.be/dZzAxYrUMRg ) and it still doesn't work. I tried troubleshooting it myself and it still isn't working. This is the error message I get: Error main.lua:28: attempt to call global 'sti...