Search found 41 matches

by khamarr3524
Sat Feb 24, 2018 9:06 am
Forum: Support and Development
Topic: Ellipsis not working?
Replies: 9
Views: 1350

Re: Ellipsis not working?

That makes sense. I think I'm going to move away from ellipsis for a different reason, but at least I know now how if I want to do it I can. Thanks for the clarification @pgimeno
by khamarr3524
Fri Feb 23, 2018 7:18 am
Forum: Support and Development
Topic: Ellipsis not working?
Replies: 9
Views: 1350

Re: Ellipsis not working?

Unless there was a change (which is quite likely) from Lua 5.0 to 5.2 concerning ellipsis, lua default populates the global arg table with ellipsis, as seen here. Although it would make sense if Love2d is intentionally using the global arg table to retain the .exe args which is what you are saying.
by khamarr3524
Fri Feb 23, 2018 6:58 am
Forum: Support and Development
Topic: Ellipsis not working?
Replies: 9
Views: 1350

Re: Ellipsis not working?

That's a workaround that will work, but there is still an underlying cause as to why Love is hijacking the ellipsis that would be interesting to find out what's causing it.
by khamarr3524
Fri Feb 23, 2018 6:40 am
Forum: Support and Development
Topic: Ellipsis not working?
Replies: 9
Views: 1350

Ellipsis not working?

So, couldn't find anything (not counting the shape) besides a post from 2009 on the use of ellipsis (...) in Love2D. For some reason, when I invoke an ellipsis it doesn't pass the args I gave it, it's passing the args called when love is run, I.E the project directory and the -debug flag (I'm using ...
by khamarr3524
Sun Feb 18, 2018 7:48 am
Forum: Support and Development
Topic: Getting Image from Spritebatch
Replies: 0
Views: 621

Getting Image from Spritebatch

So, I'm trying to use Light_World.lua alongside STI and am struggling to get Normals mapped properly. I'm taking tilesets and using them in Tiled and using STI to render them, but after adding Light_World, I found the need to use Normal Maps to properly light tiles. The problem with this is for the ...
by khamarr3524
Thu Feb 15, 2018 7:29 am
Forum: General
Topic: Unit Testing and CI with Löve2D
Replies: 2
Views: 801

Re: Unit Testing and CI with Löve2D

It reduces the file size. It isn't a big deal yet, but its something I won't have to worry about in the future. Also, when you create a love2d game .exe file its basically just a zip file you can open up.
by khamarr3524
Thu Feb 15, 2018 6:02 am
Forum: General
Topic: Unit Testing and CI with Löve2D
Replies: 2
Views: 801

Unit Testing and CI with Löve2D

So, no questions or anything but I'm just super stoked to have gotten this whole process done. As someone with minimal Linux experience and minimal CI experience, I was able to go from nothing to having a docker container running Jenkins in a CentOS virtual machine pull my repo on commit, run unit t...
by khamarr3524
Mon Apr 03, 2017 11:51 pm
Forum: Support and Development
Topic: Running Lua Bytecode
Replies: 6
Views: 2440

Re: Running Lua Bytecode

I just built and tested with LuaJIT 2.0, same thing: "Incompatible byte code"
by khamarr3524
Mon Apr 03, 2017 8:50 pm
Forum: Support and Development
Topic: Running Lua Bytecode
Replies: 6
Views: 2440

Re: Running Lua Bytecode

It's mostly for performance. I did what you said before and it's telling me the byte code is incompatible. Or its saying '=' expected near char(23)
by khamarr3524
Mon Apr 03, 2017 6:44 pm
Forum: Support and Development
Topic: Running Lua Bytecode
Replies: 6
Views: 2440

Running Lua Bytecode

I'm using version 0.10.1 and cannot find the appropriate way to compile to byte code. Ive tried luac -o, and luajit -b for luajit version 2.0.5 as well as string.dump(love.filesystem.read(file)). None of these work. What's the full process for running and compiling Löve2D code to byte code?