Uninstall...

General discussion about LÖVE, Lua, game development, puns, and unicorns.
ronaldidi
Prole
Posts: 5
Joined: Tue Nov 12, 2013 7:48 pm

Uninstall...

Post by ronaldidi » Tue Nov 12, 2013 8:02 pm

Hi all

I am using a mac osX 10.9 installed recently.
Before this version I used a 10.6.x
In this last version I used to play to Mario (1.6), Edited by Stabyourself....and everything was fine. But since I have moved to 10.9, I can't use this game anymore. When I open the game Love 0.8. (Rubber Piggy) is appearing....but I'd rather see Mario..
SO I decided to look for this application on the mac and trash it....but no application named Love or Rubber is registered ...

Could anyone help me to solve this (bigggggg) issue please ?

User avatar
Davidobot
Party member
Posts: 1209
Joined: Sat Mar 31, 2012 5:18 am
Location: Cambridge, UK
Contact:

Re: Uninstall...

Post by Davidobot » Tue Nov 12, 2013 8:38 pm

There is a current problem with LOVE on Mavericks.
My projects: Raycaster, love.js v11.3 port
itch page: link
My website: link
My library: LovelyMoon

User avatar
Nixola
Inner party member
Posts: 1949
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: Uninstall...

Post by Nixola » Tue Nov 12, 2013 9:08 pm

I think that by installing LÖVE (http://love2d.org) and downloading the source version of Mari0 you could be able to run it, but I'm not sure about it (the source version of Mari0 is a zip, extract it and open the .love inside it with LÖVE)
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
Jasoco
Inner party member
Posts: 3655
Joined: Mon Jun 22, 2009 9:35 am
Location: Pennsylvania, USA
Contact:

Re: Uninstall...

Post by Jasoco » Wed Nov 13, 2013 4:14 am

There is a fixed 0.8.0 on the forum somewhere. 0.9.0 doesn't have the Mavericks problem, but Mari0 currently does not work on 0.9.0 so a fixed version of 0.8.0 was made available.

Maybe the creator can post it here.

ronaldidi
Prole
Posts: 5
Joined: Tue Nov 12, 2013 7:48 pm

Re: Uninstall...

Post by ronaldidi » Wed Nov 13, 2013 9:00 am

thanks for your answer, but I want a very simple solution, so can anyone tell me :
- how can I find "love" on my mac ==> it does not appear in "application" and nothing if I "search love" on the whole mac
- If I trash/delete it, will mario run properly ?

User avatar
shatterblast
Party member
Posts: 136
Joined: Tue Dec 11, 2012 9:47 pm
Location: Dallas, Texas, USA

Re: Uninstall...

Post by shatterblast » Wed Nov 13, 2013 9:43 am

Jasoco wrote:There is a fixed 0.8.0 on the forum somewhere. 0.9.0 doesn't have the Mavericks problem, but Mari0 currently does not work on 0.9.0 so a fixed version of 0.8.0 was made available.
I believe the thread that Jasoco refers to is here:

http://love2d.org/forums/viewtopic.php?f=3&t=74372
ronaldidi wrote:- If I trash/delete it, will mario run properly ?
No. You should try to install the updated version of 0.8.0 in the thread posted above. Unfortunately, I can't help with that.

ronaldidi
Prole
Posts: 5
Joined: Tue Nov 12, 2013 7:48 pm

Re: Uninstall...

Post by ronaldidi » Wed Nov 13, 2013 10:40 am

I tried, but nothing changes.

I don't understand why I can't uninstall Love !!!??? Mario does not need "love " to run, does it ?

User avatar
DaedalusYoung
Party member
Posts: 402
Joined: Sun Jul 14, 2013 8:04 pm

Re: Uninstall...

Post by DaedalusYoung » Wed Nov 13, 2013 12:46 pm

ronaldidi wrote:- how can I find "love" on my mac ==> it does not appear in "application" and nothing if I "search love" on the whole mac
If it's not in Applications and you can't find it, then I would say it is not installed to begin with.

How did you install Mavericks? Did you get the installer program from the App Store? Or did you do a clean install? The installer of course is not supposed to delete anything, so are you sure you had LÖVE installed prior to your Mavericks installation? Or did you only have a Mari0 app possibly?

In Finder, open the 'Go' menu, then select 'Go to Folder' (or hit shift + Cmd + G). In the dialog that comes up, type '~/Library/Application Support' (without quotes). In this folder, see if you can find a 'LOVE' folder. If that is not there, then you do not have LÖVE installed.

ronaldidi
Prole
Posts: 5
Joined: Tue Nov 12, 2013 7:48 pm

Re: Uninstall...

Post by ronaldidi » Wed Nov 13, 2013 7:49 pm

yes, It's there. :joker: well done mister. Mario was installed before Mavericks, and I don't think LÖVE was in place. I did the install from the Appstore..bad Idea ?

and now ? trash ?
Attachments
Capture d’écran 2013-11-13 à 20.43.59.png
screenshot love
Capture d’écran 2013-11-13 à 20.43.59.png (67.47 KiB) Viewed 6173 times

User avatar
DaedalusYoung
Party member
Posts: 402
Joined: Sun Jul 14, 2013 8:04 pm

Re: Uninstall...

Post by DaedalusYoung » Wed Nov 13, 2013 8:16 pm

Do you have a Mari0 app in your Applications?

No, Mavericks from App Store is the way to go, was just wondering if you'd gotten a dev version or something like that, but it certainly shouldn't interfere with any already installed software.

Post Reply

Who is online

Users browsing this forum: No registered users and 32 guests